summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeffrey Pfau <jeffrey@endrift.com>2016-11-10 08:05:46 +0100
committerJeffrey Pfau <jeffrey@endrift.com>2016-12-13 18:41:55 +0100
commit07ab936f1246ae91c83c70b2d80b695c6883f28a (patch)
treea011671d656d719e561fc38d4cea4fc308b94937 /CMakeLists.txt
parentMerge pull request #2315 from JamePeng/fix-gsp_gpu-code (diff)
downloadyuzu-07ab936f1246ae91c83c70b2d80b695c6883f28a.tar
yuzu-07ab936f1246ae91c83c70b2d80b695c6883f28a.tar.gz
yuzu-07ab936f1246ae91c83c70b2d80b695c6883f28a.tar.bz2
yuzu-07ab936f1246ae91c83c70b2d80b695c6883f28a.tar.lz
yuzu-07ab936f1246ae91c83c70b2d80b695c6883f28a.tar.xz
yuzu-07ab936f1246ae91c83c70b2d80b695c6883f28a.tar.zst
yuzu-07ab936f1246ae91c83c70b2d80b695c6883f28a.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c02c96840..2c00690c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -183,8 +183,10 @@ IF (APPLE)
FIND_LIBRARY(COCOA_LIBRARY Cocoa) # Umbrella framework for everything GUI-related
set(PLATFORM_LIBRARIES ${COCOA_LIBRARY} ${IOKIT_LIBRARY} ${COREVIDEO_LIBRARY})
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -stdlib=libc++")
+ if (CMAKE_CXX_COMPILER_ID STREQUAL Clang)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -stdlib=libc++")
+ endif()
ELSEIF (WIN32)
# WSAPoll and SHGetKnownFolderPath (AppData/Roaming) didn't exist before WinNT 6.x (Vista)
add_definitions(-D_WIN32_WINNT=0x0600 -DWINVER=0x0600)