summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2017-08-04 02:37:03 +0200
committerGitHub <noreply@github.com>2017-08-04 02:37:03 +0200
commit0dc285dcfd1085c7725b7db474266371226de672 (patch)
tree1246eca78bc61a5122c12804f3bc70b93245118d /CMakeLists.txt
parentMerge pull request #2850 from j-selby/fix_invalid_paths (diff)
parenttelemetry: Add field for OsPlatform. (diff)
downloadyuzu-0dc285dcfd1085c7725b7db474266371226de672.tar
yuzu-0dc285dcfd1085c7725b7db474266371226de672.tar.gz
yuzu-0dc285dcfd1085c7725b7db474266371226de672.tar.bz2
yuzu-0dc285dcfd1085c7725b7db474266371226de672.tar.lz
yuzu-0dc285dcfd1085c7725b7db474266371226de672.tar.xz
yuzu-0dc285dcfd1085c7725b7db474266371226de672.tar.zst
yuzu-0dc285dcfd1085c7725b7db474266371226de672.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 79d8046d9..ddba04ef9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -295,11 +295,18 @@ function(create_directory_groups)
endforeach()
endfunction()
-# generate git revision information
+# Gets a UTC timstamp and sets the provided variable to it
+function(get_timestamp _var)
+ string(TIMESTAMP timestamp UTC)
+ set(${_var} "${timestamp}" PARENT_SCOPE)
+endfunction()
+
+# generate git/build information
include(GetGitRevisionDescription)
get_git_head_revision(GIT_REF_SPEC GIT_REV)
git_describe(GIT_DESC --always --long --dirty)
git_branch_name(GIT_BRANCH)
+get_timestamp(BUILD_DATE)
enable_testing()
add_subdirectory(externals)