summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-17 01:12:47 +0200
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-17 01:12:47 +0200
commit12e58917c0280ef8dcb2e94cd9a02bac03c3d27a (patch)
tree057653e34546b3055e653e48847642526c727d01 /CMakeLists.txt
parentMerge pull request #6201 from bunnei/remove-bintray (diff)
downloadyuzu-12e58917c0280ef8dcb2e94cd9a02bac03c3d27a.tar
yuzu-12e58917c0280ef8dcb2e94cd9a02bac03c3d27a.tar.gz
yuzu-12e58917c0280ef8dcb2e94cd9a02bac03c3d27a.tar.bz2
yuzu-12e58917c0280ef8dcb2e94cd9a02bac03c3d27a.tar.lz
yuzu-12e58917c0280ef8dcb2e94cd9a02bac03c3d27a.tar.xz
yuzu-12e58917c0280ef8dcb2e94cd9a02bac03c3d27a.tar.zst
yuzu-12e58917c0280ef8dcb2e94cd9a02bac03c3d27a.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 11 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4a6da2e1..e208715d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -274,17 +274,19 @@ if (ENABLE_SDL2)
target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARY}")
target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
else()
- find_package(SDL2 REQUIRED)
+ find_package(SDL2 2.0.12)
- # Some installations don't set SDL2_LIBRARIES
- if("${SDL2_LIBRARIES}" STREQUAL "")
- message(WARNING "SDL2_LIBRARIES wasn't set, manually setting to SDL2::SDL2")
- set(SDL2_LIBRARIES "SDL2::SDL2")
- endif()
+ if(SDL2_FOUND)
+ # Some installations don't set SDL2_LIBRARIES
+ if("${SDL2_LIBRARIES}" STREQUAL "")
+ message(WARNING "SDL2_LIBRARIES wasn't set, manually setting to SDL2::SDL2")
+ set(SDL2_LIBRARIES "SDL2::SDL2")
+ endif()
- include_directories(SYSTEM ${SDL2_INCLUDE_DIRS})
- add_library(SDL2 INTERFACE)
- target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARIES}")
+ include_directories(SYSTEM ${SDL2_INCLUDE_DIRS})
+ add_library(SDL2 INTERFACE)
+ target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARIES}")
+ endif()
endif()
else()
set(SDL2_FOUND NO)