summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian Clinkenbeard <brianclinkenbeard@users.noreply.github.com>2020-02-17 22:01:40 +0100
committerBrian Clinkenbeard <brianclinkenbeard@users.noreply.github.com>2020-02-17 22:01:40 +0100
commit13b02a14144a7b3822e4fac89caa6f7148637181 (patch)
tree22417635c1bbb2bc9a57743ae21856ab1c5277ad /CMakeLists.txt
parentMerge pull request #3420 from namkazt/master2 (diff)
downloadyuzu-13b02a14144a7b3822e4fac89caa6f7148637181.tar
yuzu-13b02a14144a7b3822e4fac89caa6f7148637181.tar.gz
yuzu-13b02a14144a7b3822e4fac89caa6f7148637181.tar.bz2
yuzu-13b02a14144a7b3822e4fac89caa6f7148637181.tar.lz
yuzu-13b02a14144a7b3822e4fac89caa6f7148637181.tar.xz
yuzu-13b02a14144a7b3822e4fac89caa6f7148637181.tar.zst
yuzu-13b02a14144a7b3822e4fac89caa6f7148637181.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44ed4196d..467d769a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -157,8 +157,14 @@ if (ENABLE_SDL2)
target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
else()
find_package(SDL2 REQUIRED)
- include_directories(${SDL2_INCLUDE_DIRS})
+ # Some installations don't set SDL2_LIBRARIES
+ if("${SDL2_LIBRARIES}" STREQUAL "")
+ message(WARNING "SDL2_LIBRARIES wasn't set, manually setting to SDL2::SDL2")
+ set(SDL2_LIBRARIES "SDL2::SDL2")
+ endif()
+
+ include_directories(${SDL2_INCLUDE_DIRS})
add_library(SDL2 INTERFACE)
target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARIES}")
endif()