summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2018-01-20 08:46:04 +0100
committerJames Rowe <jroweboy@gmail.com>2018-01-21 00:44:48 +0100
commit1e662e6e9a8d004aea1495a98af1118c87405223 (patch)
tree02ae528c4c4a80efe987b31869ac703985523b07 /CMakeLists.txt
parentCMake: Update contributing guide with the new clang format info (diff)
downloadyuzu-1e662e6e9a8d004aea1495a98af1118c87405223.tar
yuzu-1e662e6e9a8d004aea1495a98af1118c87405223.tar.gz
yuzu-1e662e6e9a8d004aea1495a98af1118c87405223.tar.bz2
yuzu-1e662e6e9a8d004aea1495a98af1118c87405223.tar.lz
yuzu-1e662e6e9a8d004aea1495a98af1118c87405223.tar.xz
yuzu-1e662e6e9a8d004aea1495a98af1118c87405223.tar.zst
yuzu-1e662e6e9a8d004aea1495a98af1118c87405223.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 992cab995..5dee41abc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,14 +3,17 @@ cmake_minimum_required(VERSION 3.6)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/CMakeModules")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/externals/cmake-modules")
include(DownloadExternals)
+include(CMakeDependentOption)
project(yuzu)
+# Set bundled sdl2/qt as dependent options.
+# OFF by default, but if ENABLE_SDL2 and MSVC are true then ON
option(ENABLE_SDL2 "Enable the SDL2 frontend" ON)
-option(YUZU_USE_BUNDLED_SDL2 "Download bundled SDL2 binaries" OFF)
+CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_SDL2 "Download bundled SDL2 binaries" ON "ENABLE_SDL2;MSVC" OFF)
option(ENABLE_QT "Enable the Qt frontend" ON)
-option(YUZU_USE_BUNDLED_QT "Download bundled Qt binaries" OFF)
+CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_QT "Download bundled Qt binaries" ON "ENABLE_SDL2;MSVC" OFF)
if(NOT EXISTS ${CMAKE_SOURCE_DIR}/.git/hooks/pre-commit)
message(STATUS "Copying pre-commit hook")