summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-10 07:58:05 +0200
committerJan Beich <jbeich@FreeBSD.org>2016-10-28 01:28:30 +0200
commit2240cb2eb0178d16c7713b6084a7013e283e268b (patch)
treee74927977c9552a392ef03638354373511dcbc3e /CMakeLists.txt
parentbuild: clock_gettime() is in libc on BSDs (diff)
downloadyuzu-2240cb2eb0178d16c7713b6084a7013e283e268b.tar
yuzu-2240cb2eb0178d16c7713b6084a7013e283e268b.tar.gz
yuzu-2240cb2eb0178d16c7713b6084a7013e283e268b.tar.bz2
yuzu-2240cb2eb0178d16c7713b6084a7013e283e268b.tar.lz
yuzu-2240cb2eb0178d16c7713b6084a7013e283e268b.tar.xz
yuzu-2240cb2eb0178d16c7713b6084a7013e283e268b.tar.zst
yuzu-2240cb2eb0178d16c7713b6084a7013e283e268b.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fc4f5675..c2fbfefb8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -269,7 +269,7 @@ add_subdirectory(src)
# http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html
# http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html
# http://standards.freedesktop.org/shared-mime-info-spec/shared-mime-info-spec-latest.html
-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|OpenBSD|NetBSD")
+if(UNIX AND NOT APPLE)
install(FILES "${CMAKE_SOURCE_DIR}/dist/citra.desktop"
DESTINATION "${CMAKE_INSTALL_PREFIX}/share/applications")
install(FILES "${CMAKE_SOURCE_DIR}/dist/citra.svg"