summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-07-16 22:56:47 +0200
committerGitHub <noreply@github.com>2023-07-16 22:56:47 +0200
commit2461c78e3f9368e4a03b4c27fae207cbb1d9cfff (patch)
tree50812311958a38d27d9ebcd1cfa443b77ff1c40c /CMakeLists.txt
parentfile_sys/content_archive: Detect compressed NCAs (#11047) (diff)
parentRename variables to avoid -Wshadow warnings under GCC (diff)
downloadyuzu-2461c78e3f9368e4a03b4c27fae207cbb1d9cfff.tar
yuzu-2461c78e3f9368e4a03b4c27fae207cbb1d9cfff.tar.gz
yuzu-2461c78e3f9368e4a03b4c27fae207cbb1d9cfff.tar.bz2
yuzu-2461c78e3f9368e4a03b4c27fae207cbb1d9cfff.tar.lz
yuzu-2461c78e3f9368e4a03b4c27fae207cbb1d9cfff.tar.xz
yuzu-2461c78e3f9368e4a03b4c27fae207cbb1d9cfff.tar.zst
yuzu-2461c78e3f9368e4a03b4c27fae207cbb1d9cfff.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f8febb90..647219052 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,18 @@ option(YUZU_DOWNLOAD_TIME_ZONE_DATA "Always download time zone binaries" OFF)
CMAKE_DEPENDENT_OPTION(YUZU_USE_FASTER_LD "Check if a faster linker is available" ON "NOT WIN32" OFF)
+set(DEFAULT_ENABLE_OPENSSL ON)
+if (ANDROID OR WIN32 OR APPLE)
+ # - Windows defaults to the Schannel backend.
+ # - macOS defaults to the SecureTransport backend.
+ # - Android currently has no SSL backend as the NDK doesn't include any SSL
+ # library; a proper 'native' backend would have to go through Java.
+ # But you can force builds for those platforms to use OpenSSL if you have
+ # your own copy of it.
+ set(DEFAULT_ENABLE_OPENSSL OFF)
+endif()
+option(ENABLE_OPENSSL "Enable OpenSSL backend for ISslConnection" ${DEFAULT_ENABLE_OPENSSL})
+
# On Android, fetch and compile libcxx before doing anything else
if (ANDROID)
set(CMAKE_SKIP_INSTALL_RULES ON)
@@ -322,6 +334,10 @@ if (MINGW)
find_library(MSWSOCK_LIBRARY mswsock REQUIRED)
endif()
+if(ENABLE_OPENSSL)
+ find_package(OpenSSL 1.1.1 REQUIRED)
+endif()
+
# Please consider this as a stub
if(ENABLE_QT6 AND Qt6_LOCATION)
list(APPEND CMAKE_PREFIX_PATH "${Qt6_LOCATION}")