summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnthony J. Bentley <anthony@anjbe.name>2016-07-17 12:30:00 +0200
committerJan Beich <jbeich@FreeBSD.org>2016-10-28 01:28:30 +0200
commit26af2b644ce634c383f27b66b9d291a34d80ab30 (patch)
tree37f28ce4c8bbe831c7ab3779eb427b17d8844636 /CMakeLists.txt
parentcommon: stat64 is non-standard, hide on a random Unix (diff)
downloadyuzu-26af2b644ce634c383f27b66b9d291a34d80ab30.tar
yuzu-26af2b644ce634c383f27b66b9d291a34d80ab30.tar.gz
yuzu-26af2b644ce634c383f27b66b9d291a34d80ab30.tar.bz2
yuzu-26af2b644ce634c383f27b66b9d291a34d80ab30.tar.lz
yuzu-26af2b644ce634c383f27b66b9d291a34d80ab30.tar.xz
yuzu-26af2b644ce634c383f27b66b9d291a34d80ab30.tar.zst
yuzu-26af2b644ce634c383f27b66b9d291a34d80ab30.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7a24f04f..df7fe0cba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -105,6 +105,15 @@ else()
set(CMAKE_EXE_LINKER_FLAGS_RELEASE "/DEBUG /INCREMENTAL:NO /OPT:REF,ICF" CACHE STRING "" FORCE)
endif()
+# Set file offset size to 64 bits.
+#
+# On modern Unixes, this is typically already the case. The lone exception is
+# glibc, which may default to 32 bits. glibc allows this to be configured
+# by setting _FILE_OFFSET_BITS.
+if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ add_definitions(-D_FILE_OFFSET_BITS=64)
+endif()
+
add_definitions(-DSINGLETHREADED)
# CMake seems to only define _DEBUG on Windows
set_property(DIRECTORY APPEND PROPERTY