summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-07-07 12:13:15 +0200
committerJan Beich <jbeich@FreeBSD.org>2020-07-07 12:13:18 +0200
commit2af7e40ce698eab25ac44cd492e7546e1010f16a (patch)
tree68123a630e1c44f0fb6427d882bade62f2a66d9c /CMakeLists.txt
parentinput_common/gcadapter: add missing C++11 header required by libc++ (diff)
downloadyuzu-2af7e40ce698eab25ac44cd492e7546e1010f16a.tar
yuzu-2af7e40ce698eab25ac44cd492e7546e1010f16a.tar.gz
yuzu-2af7e40ce698eab25ac44cd492e7546e1010f16a.tar.bz2
yuzu-2af7e40ce698eab25ac44cd492e7546e1010f16a.tar.lz
yuzu-2af7e40ce698eab25ac44cd492e7546e1010f16a.tar.xz
yuzu-2af7e40ce698eab25ac44cd492e7546e1010f16a.tar.zst
yuzu-2af7e40ce698eab25ac44cd492e7546e1010f16a.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 27383bce8..cd40e5cfe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -331,8 +331,10 @@ endif()
# Ensure libusb is properly configured (based on dolphin libusb include)
find_package(LibUSB)
-add_subdirectory(externals/libusb)
-set(LIBUSB_LIBRARIES usb)
+if (NOT LIBUSB_FOUND)
+ add_subdirectory(externals/libusb)
+ set(LIBUSB_LIBRARIES usb)
+endif()
# Prefer the -pthread flag on Linux.