summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandre Bouvier <contact@amb.tf>2023-02-21 21:55:04 +0100
committerAlexandre Bouvier <contact@amb.tf>2023-02-22 01:13:35 +0100
commit2bf9602e83715264cc438feeccf102d76bc98b76 (patch)
treef00868247d1289be82c3b872699cf9a6e3457d95 /CMakeLists.txt
parentMerge pull request #9846 from merryhime/type-const (diff)
downloadyuzu-2bf9602e83715264cc438feeccf102d76bc98b76.tar
yuzu-2bf9602e83715264cc438feeccf102d76bc98b76.tar.gz
yuzu-2bf9602e83715264cc438feeccf102d76bc98b76.tar.bz2
yuzu-2bf9602e83715264cc438feeccf102d76bc98b76.tar.lz
yuzu-2bf9602e83715264cc438feeccf102d76bc98b76.tar.xz
yuzu-2bf9602e83715264cc438feeccf102d76bc98b76.tar.zst
yuzu-2bf9602e83715264cc438feeccf102d76bc98b76.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10a3de9e2..e09410a59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -242,6 +242,9 @@ endif()
if (ENABLE_WEB_SERVICE)
find_package(cpp-jwt 1.4 CONFIG)
find_package(httplib 0.12 MODULE)
+ if (NOT cpp-jwt_FOUND OR NOT httplib_FOUND)
+ find_package(OpenSSL 1.1 MODULE COMPONENTS Crypto SSL)
+ endif()
endif()
if (YUZU_TESTS)