summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2015-02-27 04:24:22 +0100
committerJames Rowe <jroweboy@gmail.com>2015-03-26 11:04:23 +0100
commit2d7008f03c15e983c76f91ef95b1361fa3313762 (patch)
tree701c67c203c814ee543a7d5a6bb289f1ffdbf203 /CMakeLists.txt
parentMore changes to the CMakeFiles for better MSVC compatibility. Added in the RelWithDebInfo target and setup copying the Qt 5 Dlls to the output directories. (diff)
downloadyuzu-2d7008f03c15e983c76f91ef95b1361fa3313762.tar
yuzu-2d7008f03c15e983c76f91ef95b1361fa3313762.tar.gz
yuzu-2d7008f03c15e983c76f91ef95b1361fa3313762.tar.bz2
yuzu-2d7008f03c15e983c76f91ef95b1361fa3313762.tar.lz
yuzu-2d7008f03c15e983c76f91ef95b1361fa3313762.tar.xz
yuzu-2d7008f03c15e983c76f91ef95b1361fa3313762.tar.zst
yuzu-2d7008f03c15e983c76f91ef95b1361fa3313762.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbfef2811..64907a271 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,8 @@ else()
add_definitions(/D_CRT_SECURE_NO_WARNINGS)
# set up output paths for executable binaries (.exe-files, and .dll-files on DLL-capable platforms)
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
- set(CMAKE_CONFIGURATION_TYPES Debug Release RelWithDebInfo CACHE TYPE INTERNAL FORCE)
+ set(CMAKE_CONFIGURATION_TYPES Debug Release RelWithDebInfo CACHE TYPE INTERNAL)
+
# Tweak optimization settings
# As far as I can tell, there's no way to override the CMake defaults while leaving user
# changes intact, so we'll just clobber everything and say sorry.
@@ -27,11 +28,11 @@ else()
# /Zi - Output debugging information
# /Zo - enahnced debug info for optimized builds
# /MDd - Multi-threaded Debug Runtime DLL
- set(CMAKE_C_FLAGS_DEBUG "${optimization_flags} /MDd /Zi /Zo" CACHE STRING "" FORCE)
- set(CMAKE_CXX_FLAGS_DEBUG "${optimization_flags} /MDd /Zi /Zo" CACHE STRING "" FORCE)
+ set(CMAKE_C_FLAGS_DEBUG "/MP /MDd /Zi" CACHE STRING "" FORCE)
+ set(CMAKE_CXX_FLAGS_DEBUG "/MP /MDd /Zi" CACHE STRING "" FORCE)
# /MD - Multi-threaded runtime DLL
- set(CMAKE_C_FLAGS_RELEASE "${optimization_flags} /MD /Zi" CACHE STRING "" FORCE)
- set(CMAKE_CXX_FLAGS_RELEASE "${optimization_flags} /MD /Zi" CACHE STRING "" FORCE)
+ set(CMAKE_C_FLAGS_RELEASE "${optimization_flags} /MD" CACHE STRING "" FORCE)
+ set(CMAKE_CXX_FLAGS_RELEASE "${optimization_flags} /MD" CACHE STRING "" FORCE)
set(CMAKE_C_FLAGS_RELWITHDEBINFO "${optimization_flags} /MD /Zi /Zo" CACHE STRING "" FORCE)
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${optimization_flags} /MD /Zi /Zo" CACHE STRING "" FORCE)