summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2017-07-09 23:52:18 +0200
committerbunnei <bunneidev@gmail.com>2017-07-12 00:33:41 +0200
commit33b012e86b846bbba1a42193cbaf34fa16b8fb93 (patch)
treecb150fa04e758e0277aa5cc4c560226c0cf9b6ff /CMakeLists.txt
parenttelemetry_session: Use TelemetryJson to submit real telemetry. (diff)
downloadyuzu-33b012e86b846bbba1a42193cbaf34fa16b8fb93.tar
yuzu-33b012e86b846bbba1a42193cbaf34fa16b8fb93.tar.gz
yuzu-33b012e86b846bbba1a42193cbaf34fa16b8fb93.tar.bz2
yuzu-33b012e86b846bbba1a42193cbaf34fa16b8fb93.tar.lz
yuzu-33b012e86b846bbba1a42193cbaf34fa16b8fb93.tar.xz
yuzu-33b012e86b846bbba1a42193cbaf34fa16b8fb93.tar.zst
yuzu-33b012e86b846bbba1a42193cbaf34fa16b8fb93.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4668d4bea..ad73cf495 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,8 @@ option(CITRA_USE_BUNDLED_SDL2 "Download bundled SDL2 binaries" OFF)
option(ENABLE_QT "Enable the Qt frontend" ON)
option(CITRA_USE_BUNDLED_QT "Download bundled Qt binaries" OFF)
+option(ENABLE_WEB_SERVICE "Enable web services (telemetry, etc.)" ON)
+
if(NOT EXISTS ${CMAKE_SOURCE_DIR}/.git/hooks/pre-commit)
message(STATUS "Copying pre-commit hook")
file(COPY hooks/pre-commit
@@ -223,6 +225,9 @@ if (ENABLE_QT)
find_package(Qt5 REQUIRED COMPONENTS Widgets OpenGL ${QT_PREFIX_HINT})
endif()
+if (ENABLE_WEB_SERVICE)
+ add_definitions(-DENABLE_WEB_SERVICE)
+endif()
# Platform-specific library requirements
# ======================================