summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFearlessTobi <thm.frey@gmail.com>2020-01-26 00:26:07 +0100
committerFearlessTobi <thm.frey@gmail.com>2020-07-18 14:09:11 +0200
commit347b50ad439f184f0414bf978791f62b7a7c7017 (patch)
treebacfca25cb24af83222d2dfb70121c47009ebfd6 /CMakeLists.txt
parentMerge pull request #4348 from lioncash/nano (diff)
downloadyuzu-347b50ad439f184f0414bf978791f62b7a7c7017.tar
yuzu-347b50ad439f184f0414bf978791f62b7a7c7017.tar.gz
yuzu-347b50ad439f184f0414bf978791f62b7a7c7017.tar.bz2
yuzu-347b50ad439f184f0414bf978791f62b7a7c7017.tar.lz
yuzu-347b50ad439f184f0414bf978791f62b7a7c7017.tar.xz
yuzu-347b50ad439f184f0414bf978791f62b7a7c7017.tar.zst
yuzu-347b50ad439f184f0414bf978791f62b7a7c7017.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce46a2c2b..7a49318aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ project(yuzu)
option(ENABLE_SDL2 "Enable the SDL2 frontend" ON)
option(ENABLE_QT "Enable the Qt frontend" ON)
+option(ENABLE_QT_TRANSLATION "Enable translations for the Qt frontend" OFF)
CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_QT "Download bundled Qt binaries" ON "ENABLE_QT;MSVC" OFF)
option(ENABLE_WEB_SERVICE "Enable web services (telemetry, etc.)" ON)
@@ -224,6 +225,10 @@ if(ENABLE_QT)
if (YUZU_USE_QT_WEB_ENGINE)
find_package(Qt5 COMPONENTS WebEngineCore WebEngineWidgets)
endif()
+
+ if (ENABLE_QT_TRANSLATION)
+ find_package(Qt5 REQUIRED COMPONENTS LinguistTools ${QT_PREFIX_HINT})
+ endif()
if (NOT Qt5_FOUND)
list(APPEND CONAN_REQUIRED_LIBS "qt/5.14.1@bincrafters/stable")
endif()