summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfreiro <f73b2894@opayq.com>2016-11-30 15:59:26 +0100
committerfreiro <f73b2894@opayq.com>2016-11-30 16:28:21 +0100
commit35e979f041aed8a5fc1da3dde254ce11e6138562 (patch)
treef0a7a46b6419f6ed6a901d9d8f42add39243cb6b /CMakeLists.txt
parentWINVER definition moved to CMake and cleanup (diff)
downloadyuzu-35e979f041aed8a5fc1da3dde254ce11e6138562.tar
yuzu-35e979f041aed8a5fc1da3dde254ce11e6138562.tar.gz
yuzu-35e979f041aed8a5fc1da3dde254ce11e6138562.tar.bz2
yuzu-35e979f041aed8a5fc1da3dde254ce11e6138562.tar.lz
yuzu-35e979f041aed8a5fc1da3dde254ce11e6138562.tar.xz
yuzu-35e979f041aed8a5fc1da3dde254ce11e6138562.tar.zst
yuzu-35e979f041aed8a5fc1da3dde254ce11e6138562.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a78028bc..33d18f5ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -183,12 +183,12 @@ IF (APPLE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -stdlib=libc++")
ELSEIF (WIN32)
- #WSAPoll and other fileutil.cpp functionalities didn't exist before WinNT 6.x (Vista and up)
+ # WSAPoll and SHGetKnownFolderPath (AppData/Roaming) didn't exist before WinNT 6.x (Vista)
add_definitions(-D_WIN32_WINNT=0x0600 -DWINVER=0x0600)
set(PLATFORM_LIBRARIES winmm ws2_32)
- if (MINGW)
+ IF (MINGW)
# PSAPI is the Process Status API
- set(PLATFORM_LIBRARIES winmm ws2_32 psapi imm32 version)
+ set(PLATFORM_LIBRARIES ${PLATFORM_LIBRARIES} psapi imm32 version)
ENDIF (MINGW)
ELSEIF (CMAKE_SYSTEM_NAME MATCHES "^(Linux|kFreeBSD|GNU|SunOS)$")
set(PLATFORM_LIBRARIES rt)