summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHarry Prevor <habs@sdf.org>2018-01-15 03:48:01 +0100
committerHarry Prevor <habs@sdf.org>2018-01-15 03:48:01 +0100
commit554cc9488ffb74d601bc800b886f0530be1aac49 (patch)
treedc91449172a6e9e021cbdf7ab931d4254d2c88aa /CMakeLists.txt
parentMerge pull request #10 from Andrix44/mpwarnings (diff)
downloadyuzu-554cc9488ffb74d601bc800b886f0530be1aac49.tar
yuzu-554cc9488ffb74d601bc800b886f0530be1aac49.tar.gz
yuzu-554cc9488ffb74d601bc800b886f0530be1aac49.tar.bz2
yuzu-554cc9488ffb74d601bc800b886f0530be1aac49.tar.lz
yuzu-554cc9488ffb74d601bc800b886f0530be1aac49.tar.xz
yuzu-554cc9488ffb74d601bc800b886f0530be1aac49.tar.zst
yuzu-554cc9488ffb74d601bc800b886f0530be1aac49.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09fe9bcd3..2af11a4e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,6 +134,12 @@ else()
set(CMAKE_EXE_LINKER_FLAGS_RELEASE "/DEBUG /MANIFEST:NO /INCREMENTAL:NO /OPT:REF,ICF" CACHE STRING "" FORCE)
endif()
+# Fix GCC C++17 and Boost.ICL incompatibility (needed to build dynarmic)
+# See https://bugzilla.redhat.com/show_bug.cgi?id=1485641#c1
+if (CMAKE_COMPILER_IS_GNUCC)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-new-ttp-matching")
+endif()
+
# Set file offset size to 64 bits.
#
# On modern Unixes, this is typically already the case. The lone exception is