summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMerryMage <MerryMage@users.noreply.github.com>2020-07-11 15:37:34 +0200
committerMerryMage <MerryMage@users.noreply.github.com>2020-07-11 15:37:34 +0200
commit6744e7ea4a2e00ac2a481045f036a282b85fc0b1 (patch)
treeda78bf08d0e5c352388b1f7cee4f5f04eb4c3c79 /CMakeLists.txt
parentMerge pull request #4203 from VolcaEM/services (diff)
downloadyuzu-6744e7ea4a2e00ac2a481045f036a282b85fc0b1.tar
yuzu-6744e7ea4a2e00ac2a481045f036a282b85fc0b1.tar.gz
yuzu-6744e7ea4a2e00ac2a481045f036a282b85fc0b1.tar.bz2
yuzu-6744e7ea4a2e00ac2a481045f036a282b85fc0b1.tar.lz
yuzu-6744e7ea4a2e00ac2a481045f036a282b85fc0b1.tar.xz
yuzu-6744e7ea4a2e00ac2a481045f036a282b85fc0b1.tar.zst
yuzu-6744e7ea4a2e00ac2a481045f036a282b85fc0b1.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c0e49c03..88ea04c08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -330,14 +330,15 @@ elseif(SDL2_FOUND)
endif()
# Ensure libusb is properly configured (based on dolphin libusb include)
-include(FindPkgConfig)
-find_package(LibUSB)
+if(NOT APPLE)
+ include(FindPkgConfig)
+ find_package(LibUSB)
+endif()
if (NOT LIBUSB_FOUND)
add_subdirectory(externals/libusb)
set(LIBUSB_LIBRARIES usb)
endif()
-
# Prefer the -pthread flag on Linux.
set(THREADS_PREFER_PTHREAD_FLAG ON)
find_package(Threads REQUIRED)