summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2015-09-09 01:16:34 +0200
committerYuri Kunde Schlesner <yuriks@yuriks.net>2015-09-09 01:16:34 +0200
commit6cec3301032bb70abb99cb9aa77bf432ab714281 (patch)
tree2e505fb240cf11f0043cd40adbd07d48210b3332 /CMakeLists.txt
parentMerge pull request #1020 from yuriks/qt-binaries (diff)
downloadyuzu-6cec3301032bb70abb99cb9aa77bf432ab714281.tar
yuzu-6cec3301032bb70abb99cb9aa77bf432ab714281.tar.gz
yuzu-6cec3301032bb70abb99cb9aa77bf432ab714281.tar.bz2
yuzu-6cec3301032bb70abb99cb9aa77bf432ab714281.tar.lz
yuzu-6cec3301032bb70abb99cb9aa77bf432ab714281.tar.xz
yuzu-6cec3301032bb70abb99cb9aa77bf432ab714281.tar.zst
yuzu-6cec3301032bb70abb99cb9aa77bf432ab714281.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0bf2df504..fa6463b01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,13 @@ endfunction()
project(citra)
+option(ENABLE_GLFW "Enable the GLFW frontend" ON)
+option(CITRA_USE_BUNDLED_GLFW "Download bundled GLFW binaries" OFF)
+
+option(ENABLE_QT "Enable the Qt frontend" ON)
+option(CITRA_USE_BUNDLED_QT "Download bundled Qt binaries" OFF)
+option(CITRA_FORCE_QT4 "Use Qt4 even if Qt5 is available." OFF)
+
if(NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git/hooks/pre-commit)
message(STATUS "Copying pre-commit hook")
file(COPY hooks/pre-commit
@@ -129,8 +136,6 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/externals/cmake-modules")
find_package(OpenGL REQUIRED)
include_directories(${OPENGL_INCLUDE_DIR})
-option(ENABLE_GLFW "Enable the GLFW frontend" ON)
-option(CITRA_USE_BUNDLED_GLFW "Download bundled GLFW binaries" OFF)
if (ENABLE_GLFW)
if (CITRA_USE_BUNDLED_GLFW)
# Detect toolchain and platform
@@ -176,9 +181,6 @@ ELSE()
set(PLATFORM_LIBRARIES rt)
ENDIF (APPLE)
-option(ENABLE_QT "Enable the Qt frontend" ON)
-option(CITRA_USE_BUNDLED_QT "Download bundled Qt binaries" OFF)
-option(CITRA_FORCE_QT4 "Use Qt4 even if Qt5 is available." OFF)
if (ENABLE_QT)
if (CITRA_USE_BUNDLED_QT)
if (MSVC14 AND ARCHITECTURE_x86_64)