summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2014-12-16 01:06:03 +0100
committerYuri Kunde Schlesner <yuriks@yuriks.net>2014-12-16 04:08:14 +0100
commit731b31fe972be473500db3a130aab79ba21a0c08 (patch)
tree703c0580d22922056ce662c67124e40a6f517e61 /CMakeLists.txt
parentTravis: Use gcc 4.9 instead of 4.8 since it's getting installed anyway (diff)
downloadyuzu-731b31fe972be473500db3a130aab79ba21a0c08.tar
yuzu-731b31fe972be473500db3a130aab79ba21a0c08.tar.gz
yuzu-731b31fe972be473500db3a130aab79ba21a0c08.tar.bz2
yuzu-731b31fe972be473500db3a130aab79ba21a0c08.tar.lz
yuzu-731b31fe972be473500db3a130aab79ba21a0c08.tar.xz
yuzu-731b31fe972be473500db3a130aab79ba21a0c08.tar.zst
yuzu-731b31fe972be473500db3a130aab79ba21a0c08.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61d5d524a..63738b5ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,8 @@ cmake_minimum_required(VERSION 2.8.11)
project(citra)
if (NOT MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-attributes")
+ # -std=c++14 is only supported on very new compilers, so use the old c++1y alias instead.
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y -Wno-attributes")
else()
# Silence deprecation warnings
add_definitions(/D_CRT_SECURE_NO_WARNINGS)