summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-01-04 19:15:29 +0100
committerbunnei <bunneidev@gmail.com>2018-01-04 19:15:29 +0100
commit738845cc0e3e3dc4833e7eca25c263aa6834192b (patch)
tree27699c7763f9de3f41e95170f3135335b7c52774 /CMakeLists.txt
parentunicorn: Use for arm interface on Windows. (diff)
downloadyuzu-738845cc0e3e3dc4833e7eca25c263aa6834192b.tar
yuzu-738845cc0e3e3dc4833e7eca25c263aa6834192b.tar.gz
yuzu-738845cc0e3e3dc4833e7eca25c263aa6834192b.tar.bz2
yuzu-738845cc0e3e3dc4833e7eca25c263aa6834192b.tar.lz
yuzu-738845cc0e3e3dc4833e7eca25c263aa6834192b.tar.xz
yuzu-738845cc0e3e3dc4833e7eca25c263aa6834192b.tar.zst
yuzu-738845cc0e3e3dc4833e7eca25c263aa6834192b.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c45c830c7..945278f88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,7 +215,7 @@ endif()
if (YUZU_USE_BUNDLED_UNICORN)
# Detect toolchain and platform
if (MSVC14 AND ARCHITECTURE_x86_64)
- set(UNICORN_VER "unicorn-1.0.1-yuzu")
+ set(UNICORN_VER "unicorn-yuzu")
else()
message(FATAL_ERROR "No bundled Unicorn binaries for your toolchain. Disable YUZU_USE_BUNDLED_UNICORN and provide your own.")
endif()
@@ -230,7 +230,8 @@ if (YUZU_USE_BUNDLED_UNICORN)
set(UNICORN_FOUND YES)
set(UNICORN_INCLUDE_DIR "${UNICORN_PREFIX}/include" CACHE PATH "Path to Unicorn headers")
- set(UNICORN_LIBRARY "${UNICORN_PREFIX}/lib/x64/unicorn_static.lib" CACHE PATH "Path to Unicorn library")
+ set(UNICORN_LIBRARY "${UNICORN_PREFIX}/lib/x64/unicorn_dynload.lib" CACHE PATH "Path to Unicorn library")
+ set(UNICORN_DLL_DIR "${UNICORN_PREFIX}/lib/x64/" CACHE PATH "Path to unicorn.dll")
else()
find_package(unicorn REQUIRED)
endif()