summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2015-06-21 23:21:02 +0200
committerYuri Kunde Schlesner <yuriks@yuriks.net>2015-06-21 23:21:02 +0200
commit772ef097ead8d6be77cf00d753e8380fcac96710 (patch)
tree70e74daf5c9d3159550c36367959727b224c8bb5 /CMakeLists.txt
parentAppVeyor: update WinSCP download link with one that should never expire (diff)
parentenforce config from hook (diff)
downloadyuzu-772ef097ead8d6be77cf00d753e8380fcac96710.tar
yuzu-772ef097ead8d6be77cf00d753e8380fcac96710.tar.gz
yuzu-772ef097ead8d6be77cf00d753e8380fcac96710.tar.bz2
yuzu-772ef097ead8d6be77cf00d753e8380fcac96710.tar.lz
yuzu-772ef097ead8d6be77cf00d753e8380fcac96710.tar.xz
yuzu-772ef097ead8d6be77cf00d753e8380fcac96710.tar.zst
yuzu-772ef097ead8d6be77cf00d753e8380fcac96710.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75f519a1d..6805ebed8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,13 @@ cmake_minimum_required(VERSION 2.8.11)
project(citra)
+if(NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git/hooks/pre-commit)
+ message(STATUS "Copying pre-commit hook")
+ file(COPY hooks/pre-commit
+ DESTINATION ${CMAKE_CURRENT_SOURCE_DIR}/.git/hooks
+ FILE_PERMISSIONS WORLD_EXECUTE )
+endif()
+
if (NOT MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-attributes -pthread")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")