summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2021-01-07 23:14:21 +0100
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2021-01-07 23:28:15 +0100
commit78be397723e2df3c3954ba24326ee69dbfa93c8a (patch)
tree91c88295eadbd21885e0db4b68c5acd44ed569ef /CMakeLists.txt
parentMerge pull request #5237 from ameerj/nvdec-syncpt (diff)
downloadyuzu-78be397723e2df3c3954ba24326ee69dbfa93c8a.tar
yuzu-78be397723e2df3c3954ba24326ee69dbfa93c8a.tar.gz
yuzu-78be397723e2df3c3954ba24326ee69dbfa93c8a.tar.bz2
yuzu-78be397723e2df3c3954ba24326ee69dbfa93c8a.tar.lz
yuzu-78be397723e2df3c3954ba24326ee69dbfa93c8a.tar.xz
yuzu-78be397723e2df3c3954ba24326ee69dbfa93c8a.tar.zst
yuzu-78be397723e2df3c3954ba24326ee69dbfa93c8a.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5793c5d57..aaf3a90cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,10 @@ option(ENABLE_CUBEB "Enables the cubeb audio backend" ON)
option(USE_DISCORD_PRESENCE "Enables Discord Rich Presence" OFF)
+if (NOT ENABLE_WEB_SERVICE)
+ set(YUZU_ENABLE_BOXCAT OFF)
+endif()
+
# Default to a Release build
get_property(IS_MULTI_CONFIG GLOBAL PROPERTY GENERATOR_IS_MULTI_CONFIG)
if (NOT IS_MULTI_CONFIG AND NOT CMAKE_BUILD_TYPE)
@@ -239,7 +243,7 @@ if(ENABLE_QT)
if (YUZU_USE_QT_WEB_ENGINE)
find_package(Qt5 COMPONENTS WebEngineCore WebEngineWidgets)
endif()
-
+
if (ENABLE_QT_TRANSLATION)
find_package(Qt5 REQUIRED COMPONENTS LinguistTools ${QT_PREFIX_HINT})
endif()
@@ -322,7 +326,7 @@ if (CONAN_REQUIRED_LIBS)
list(APPEND Boost_LIBRARIES Boost::context)
endif()
endif()
-
+
# Due to issues with variable scopes in functions, we need to also find_package(qt5) outside of the function
if(ENABLE_QT)
list(APPEND CMAKE_MODULE_PATH "${CONAN_QT_ROOT_RELEASE}")