summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandre Bouvier <contact@amb.tf>2023-01-05 05:00:44 +0100
committerAlexandre Bouvier <contact@amb.tf>2023-01-05 05:03:34 +0100
commit7a2bd13f5bf00153fc543daa779c1037ecbe4298 (patch)
treeb7911b75d3742ea366376d73f95e020d6ec018a6 /CMakeLists.txt
parenttests: update catch2 to 3.0.1 (diff)
downloadyuzu-7a2bd13f5bf00153fc543daa779c1037ecbe4298.tar
yuzu-7a2bd13f5bf00153fc543daa779c1037ecbe4298.tar.gz
yuzu-7a2bd13f5bf00153fc543daa779c1037ecbe4298.tar.bz2
yuzu-7a2bd13f5bf00153fc543daa779c1037ecbe4298.tar.lz
yuzu-7a2bd13f5bf00153fc543daa779c1037ecbe4298.tar.xz
yuzu-7a2bd13f5bf00153fc543daa779c1037ecbe4298.tar.zst
yuzu-7a2bd13f5bf00153fc543daa779c1037ecbe4298.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 658a2816b..f91ba950a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,12 +3,14 @@
cmake_minimum_required(VERSION 3.22)
+project(yuzu)
+
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/CMakeModules")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/externals/cmake-modules")
+
include(DownloadExternals)
include(CMakeDependentOption)
-
-project(yuzu)
+include(CTest)
# Set bundled sdl2/qt as dependent options.
# OFF by default, but if ENABLE_SDL2 and MSVC are true then ON
@@ -42,7 +44,7 @@ option(ENABLE_CUBEB "Enables the cubeb audio backend" ON)
option(USE_DISCORD_PRESENCE "Enables Discord Rich Presence" OFF)
-option(YUZU_TESTS "Compile tests" ON)
+option(YUZU_TESTS "Compile tests" "${BUILD_TESTING}")
option(YUZU_USE_PRECOMPILED_HEADERS "Use precompiled headers" ON)
@@ -606,7 +608,6 @@ if (YUZU_USE_FASTER_LD AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
endif()
endif()
-enable_testing()
add_subdirectory(externals)
add_subdirectory(src)