summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFeng Chen <chen.feng@glority.cn>2023-08-17 03:17:56 +0200
committerFeng Chen <vonchenplus@gmail.com>2023-08-22 04:22:28 +0200
commit87022a4833fd693274275e1153d80d2e56fe0b11 (patch)
tree331327060ac062ec1584a0c86c7adbd5ccf436f1 /CMakeLists.txt
parentMerge pull request #11287 from liamwhite/replaced-bytes (diff)
downloadyuzu-87022a4833fd693274275e1153d80d2e56fe0b11.tar
yuzu-87022a4833fd693274275e1153d80d2e56fe0b11.tar.gz
yuzu-87022a4833fd693274275e1153d80d2e56fe0b11.tar.bz2
yuzu-87022a4833fd693274275e1153d80d2e56fe0b11.tar.lz
yuzu-87022a4833fd693274275e1153d80d2e56fe0b11.tar.xz
yuzu-87022a4833fd693274275e1153d80d2e56fe0b11.tar.zst
yuzu-87022a4833fd693274275e1153d80d2e56fe0b11.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af9f394f1..7858d0450 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,7 +49,7 @@ option(YUZU_TESTS "Compile tests" "${BUILD_TESTING}")
option(YUZU_USE_PRECOMPILED_HEADERS "Use precompiled headers" ON)
-cmake_dependent_option(YUZU_ROOM "Compile LDN room server" ON "NOT ANDROID" OFF)
+CMAKE_DEPENDENT_OPTION(YUZU_ROOM "Compile LDN room server" ON "NOT ANDROID" OFF)
CMAKE_DEPENDENT_OPTION(YUZU_CRASH_DUMPS "Compile Windows crash dump (Minidump) support" OFF "WIN32" OFF)
@@ -63,6 +63,8 @@ option(YUZU_DOWNLOAD_TIME_ZONE_DATA "Always download time zone binaries" OFF)
CMAKE_DEPENDENT_OPTION(YUZU_USE_FASTER_LD "Check if a faster linker is available" ON "NOT WIN32" OFF)
+CMAKE_DEPENDENT_OPTION(USE_SYSTEM_MOLTENVK "Use the system MoltenVK lib (instead of the bundled one)" OFF "APPLE" OFF)
+
set(DEFAULT_ENABLE_OPENSSL ON)
if (ANDROID OR WIN32 OR APPLE)
# - Windows defaults to the Schannel backend.