summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2015-01-13 20:47:45 +0100
committerYuri Kunde Schlesner <yuriks@yuriks.net>2015-01-19 22:40:43 +0100
commit8c39324333a7f16e5c4161f5e62dbef3e9721330 (patch)
treedec8d514f171128c77f970c78a6498648aabe36a /CMakeLists.txt
parentCMake: Fix wrong filename in message (diff)
downloadyuzu-8c39324333a7f16e5c4161f5e62dbef3e9721330.tar
yuzu-8c39324333a7f16e5c4161f5e62dbef3e9721330.tar.gz
yuzu-8c39324333a7f16e5c4161f5e62dbef3e9721330.tar.bz2
yuzu-8c39324333a7f16e5c4161f5e62dbef3e9721330.tar.lz
yuzu-8c39324333a7f16e5c4161f5e62dbef3e9721330.tar.xz
yuzu-8c39324333a7f16e5c4161f5e62dbef3e9721330.tar.zst
yuzu-8c39324333a7f16e5c4161f5e62dbef3e9721330.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a743a2109..567e9533f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,8 +66,11 @@ if (ENABLE_GLFW)
if (MSVC)
if (CMAKE_SIZEOF_VOID_P EQUAL 8)
set(TMP_ARCH "x64")
- else()
+ elseif (CMAKE_SIZEOF_VOID_P EQUAL 4)
set(TMP_ARCH "Win32")
+ else()
+ set(TMP_ARCH "UNKNOWN")
+ message(SEND_ERROR "Couldn't detect your compiler's architecture, you'll have to manually specify the GLFW library to use. (Try checking CMakeOutput.log to find out why.)")
endif()
if (MSVC11) # Visual C++ 2012
@@ -84,8 +87,11 @@ if (ENABLE_GLFW)
# Assume mingw
if (CMAKE_SIZEOF_VOID_P EQUAL 8)
set(TMP_ARCH "x86_64")
- else()
+ elseif (CMAKE_SIZEOF_VOID_P EQUAL 4)
set(TMP_ARCH "i686")
+ else()
+ set(TMP_ARCH "UNKNOWN")
+ message(SEND_ERROR "Couldn't detect your compiler's architecture, you'll have to manually specify the GLFW library to use.")
endif()
set(TMP_TOOLSET "mingw-${TMP_ARCH}")