summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLiam <byteslice@airmail.cc>2022-12-10 21:12:27 +0100
committerLiam <byteslice@airmail.cc>2022-12-10 21:12:27 +0100
commit8d1d6e149f4929227b00084f7a14f4c701348119 (patch)
treea5427fe0489cc7547b2c4be03c1c4f9487483599 /CMakeLists.txt
parentMerge pull request #9417 from liamwhite/debug-assert (diff)
downloadyuzu-8d1d6e149f4929227b00084f7a14f4c701348119.tar
yuzu-8d1d6e149f4929227b00084f7a14f4c701348119.tar.gz
yuzu-8d1d6e149f4929227b00084f7a14f4c701348119.tar.bz2
yuzu-8d1d6e149f4929227b00084f7a14f4c701348119.tar.lz
yuzu-8d1d6e149f4929227b00084f7a14f4c701348119.tar.xz
yuzu-8d1d6e149f4929227b00084f7a14f4c701348119.tar.zst
yuzu-8d1d6e149f4929227b00084f7a14f4c701348119.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cd59e7485..9723bdf19 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,8 @@ CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_SDL2 "Download bundled SDL2 binaries" ON
# On Linux system SDL2 is likely to be lacking HIDAPI support which have drawbacks but is needed for SDL motion
CMAKE_DEPENDENT_OPTION(YUZU_USE_EXTERNAL_SDL2 "Compile external SDL2" ON "ENABLE_SDL2;NOT MSVC" OFF)
+option(ENABLE_OPENGL "Enable OpenGL" ON)
+mark_as_advanced(FORCE ENABLE_OPENGL)
option(ENABLE_QT "Enable the Qt frontend" ON)
option(ENABLE_QT6 "Allow usage of Qt6 to be attempted" OFF)
set(QT6_LOCATION "" CACHE PATH "Additional Location to search for Qt6 libraries like C:/Qt/6.3.1/msvc2019_64/")