summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandre Bouvier <contact@amb.tf>2022-11-25 19:35:46 +0100
committerAlexandre Bouvier <contact@amb.tf>2022-12-04 17:09:25 +0100
commit8e17b5469fc7f5211fc3e24841896ea030adce84 (patch)
treec5baf2ed91c115c7f07063297d2cd611e73b6713 /CMakeLists.txt
parentMerge pull request #9375 from jbeich/xbyak-no-install (diff)
downloadyuzu-8e17b5469fc7f5211fc3e24841896ea030adce84.tar
yuzu-8e17b5469fc7f5211fc3e24841896ea030adce84.tar.gz
yuzu-8e17b5469fc7f5211fc3e24841896ea030adce84.tar.bz2
yuzu-8e17b5469fc7f5211fc3e24841896ea030adce84.tar.lz
yuzu-8e17b5469fc7f5211fc3e24841896ea030adce84.tar.xz
yuzu-8e17b5469fc7f5211fc3e24841896ea030adce84.tar.zst
yuzu-8e17b5469fc7f5211fc3e24841896ea030adce84.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt39
1 files changed, 26 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index facf4ea5f..1200c14bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,8 +43,6 @@ option(ENABLE_CUBEB "Enables the cubeb audio backend" ON)
option(USE_DISCORD_PRESENCE "Enables Discord Rich Presence" OFF)
-option(YUZU_USE_BUNDLED_OPUS "Compile bundled opus" ON)
-
option(YUZU_TESTS "Compile tests" ON)
option(YUZU_USE_PRECOMPILED_HEADERS "Use precompiled headers" ON)
@@ -201,24 +199,39 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/bin)
# System imported libraries
# =======================================================================
-find_package(fmt 8.0.1 REQUIRED CONFIG)
-find_package(nlohmann_json 3.8 REQUIRED CONFIG)
+find_package(enet 1.3)
+find_package(fmt 9 REQUIRED)
+find_package(inih)
+find_package(lz4 1.8 REQUIRED)
+find_package(nlohmann_json 3.8 REQUIRED)
+find_package(Opus 1.3)
+find_package(Vulkan 1.3.213)
find_package(ZLIB 1.2 REQUIRED)
+find_package(zstd 1.5 REQUIRED)
+
+if (ARCHITECTURE_x86 OR ARCHITECTURE_x86_64)
+ find_package(xbyak 6)
+endif()
+
+if (ARCHITECTURE_x86_64 OR ARCHITECTURE_arm64)
+ find_package(dynarmic 6.2.4)
+endif()
+
+if (ENABLE_CUBEB)
+ find_package(cubeb)
+endif()
-# Search for config-only package first (for vcpkg), then try non-config
-find_package(zstd 1.5 CONFIG)
-if (NOT zstd_FOUND)
- find_package(zstd 1.5 REQUIRED)
+if (USE_DISCORD_PRESENCE)
+ find_package(DiscordRPC)
endif()
-# lz4 1.8 is required, but vcpkg's lz4-config.cmake does not have version info
-find_package(lz4 CONFIG)
-if (NOT lz4_FOUND)
- find_package(lz4 1.8 REQUIRED)
+if (ENABLE_WEB_SERVICE)
+ find_package(cpp-jwt 1.4)
+ find_package(httplib 0.11)
endif()
if (YUZU_TESTS)
- find_package(Catch2 2.13.7 REQUIRED CONFIG)
+ find_package(Catch2 2.13.7 REQUIRED)
endif()
find_package(Boost 1.73.0 COMPONENTS context)