summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-01-13 01:37:23 +0100
committerbunnei <bunneidev@gmail.com>2018-01-13 01:37:23 +0100
commit941cdae6f0ceab5a1781ba68416a22a04551eaf5 (patch)
tree2be7c67b2d39b641479fd9c444b0145e1e30691e /CMakeLists.txt
parentboost: Update version. (diff)
downloadyuzu-941cdae6f0ceab5a1781ba68416a22a04551eaf5.tar
yuzu-941cdae6f0ceab5a1781ba68416a22a04551eaf5.tar.gz
yuzu-941cdae6f0ceab5a1781ba68416a22a04551eaf5.tar.bz2
yuzu-941cdae6f0ceab5a1781ba68416a22a04551eaf5.tar.lz
yuzu-941cdae6f0ceab5a1781ba68416a22a04551eaf5.tar.xz
yuzu-941cdae6f0ceab5a1781ba68416a22a04551eaf5.tar.zst
yuzu-941cdae6f0ceab5a1781ba68416a22a04551eaf5.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 19590f109..b2fd0ca81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,7 +87,7 @@ message(STATUS "Target architecture: ${ARCHITECTURE}")
# Configure compilation flags
# ===========================
-set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
if (NOT MSVC)
@@ -129,7 +129,7 @@ else()
# /EHsc - C++-only exception handling semantics
# /Zc:throwingNew - let codegen assume `operator new` will never return null
# /Zc:inline - let codegen omit inline functions in object files
- set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} /EHsc /Zc:throwingNew,inline" CACHE STRING "" FORCE)
+ set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} /EHsc /std:c++latest /Zc:throwingNew,inline" CACHE STRING "" FORCE)
# /MDd - Multi-threaded Debug Runtime DLL
set(CMAKE_C_FLAGS_DEBUG "/Od /MDd" CACHE STRING "" FORCE)