summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2014-12-22 17:11:37 +0100
committerbunnei <bunneidev@gmail.com>2014-12-22 17:11:37 +0100
commit949d95659e019d2c1bb58327827e1a9fc39b28ee (patch)
treeeca14a68ab0d253412689ec58f003c014e4d02ae /CMakeLists.txt
parentMerge pull request #333 from lioncash/qops (diff)
parentBuild GLFW as a shared lib on Travis (diff)
downloadyuzu-949d95659e019d2c1bb58327827e1a9fc39b28ee.tar
yuzu-949d95659e019d2c1bb58327827e1a9fc39b28ee.tar.gz
yuzu-949d95659e019d2c1bb58327827e1a9fc39b28ee.tar.bz2
yuzu-949d95659e019d2c1bb58327827e1a9fc39b28ee.tar.lz
yuzu-949d95659e019d2c1bb58327827e1a9fc39b28ee.tar.xz
yuzu-949d95659e019d2c1bb58327827e1a9fc39b28ee.tar.zst
yuzu-949d95659e019d2c1bb58327827e1a9fc39b28ee.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1491df6e6..5bb87d50d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,7 @@ project(citra)
if (NOT MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-attributes")
+ add_definitions(-pthread)
else()
# Silence deprecation warnings
add_definitions(/D_CRT_SECURE_NO_WARNINGS)
@@ -96,10 +97,6 @@ if (ENABLE_GLFW)
set(GLFW_LIBRARIES glfw3)
else()
- if (NOT APPLE)
- find_package(X11 REQUIRED)
- endif()
-
find_package(PkgConfig REQUIRED)
pkg_search_module(GLFW REQUIRED glfw3)
endif()