summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <user@ubuntu.(none)>2014-04-10 05:28:43 +0200
committerbunnei <user@ubuntu.(none)>2014-04-10 05:28:43 +0200
commit9527fc74add2584de861a3a40fb313304c0108a7 (patch)
treedcc9c295000a34e65d91fcefcca2e32dd1d3ae07 /CMakeLists.txt
parentupdated CMakeLists (diff)
downloadyuzu-9527fc74add2584de861a3a40fb313304c0108a7.tar
yuzu-9527fc74add2584de861a3a40fb313304c0108a7.tar.gz
yuzu-9527fc74add2584de861a3a40fb313304c0108a7.tar.bz2
yuzu-9527fc74add2584de861a3a40fb313304c0108a7.tar.lz
yuzu-9527fc74add2584de861a3a40fb313304c0108a7.tar.xz
yuzu-9527fc74add2584de861a3a40fb313304c0108a7.tar.zst
yuzu-9527fc74add2584de861a3a40fb313304c0108a7.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0adc5e6f4..6f886b21b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,15 +9,9 @@ add_definitions(-DSINGLETHREADED)
# dependency checking
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/CMakeTests)
include(FindOpenGL REQUIRED)
-include(FindGLFW REQUIRED)
include(FindX11 REQUIRED)
-if(NOT GLFW_FOUND)
- message(FATAL_ERROR "glfw not found")
-else()
- include_directories(${GLFW_INCLUDE_DIRS})
-endif()
-
+include_directories(${GLFW_INCLUDE_DIRS})
option(DISABLE_QT4 "Disable Qt4 GUI" OFF)
if(NOT DISABLE_QT4)
include(FindQt4)
@@ -33,7 +27,6 @@ if(NOT DISABLE_QT4)
endif()
# external includes
-include_directories(${SDL2_INCLUDE_DIR})
include_directories(${OPENGL_INCLUDE_DIR})
# internal includes