summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid <25727384+ogniK5377@users.noreply.github.com>2020-07-18 14:43:37 +0200
committerGitHub <noreply@github.com>2020-07-18 14:43:37 +0200
commit9943a478fe19dad4f770292b989179f71e2d10a0 (patch)
tree7c1f7d2edc8841e5e9ac2c9a49da0d4314a3f8b2 /CMakeLists.txt
parentMerge pull request #4348 from lioncash/nano (diff)
parentAddress trivial review comments. (diff)
downloadyuzu-9943a478fe19dad4f770292b989179f71e2d10a0.tar
yuzu-9943a478fe19dad4f770292b989179f71e2d10a0.tar.gz
yuzu-9943a478fe19dad4f770292b989179f71e2d10a0.tar.bz2
yuzu-9943a478fe19dad4f770292b989179f71e2d10a0.tar.lz
yuzu-9943a478fe19dad4f770292b989179f71e2d10a0.tar.xz
yuzu-9943a478fe19dad4f770292b989179f71e2d10a0.tar.zst
yuzu-9943a478fe19dad4f770292b989179f71e2d10a0.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce46a2c2b..7a49318aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ project(yuzu)
option(ENABLE_SDL2 "Enable the SDL2 frontend" ON)
option(ENABLE_QT "Enable the Qt frontend" ON)
+option(ENABLE_QT_TRANSLATION "Enable translations for the Qt frontend" OFF)
CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_QT "Download bundled Qt binaries" ON "ENABLE_QT;MSVC" OFF)
option(ENABLE_WEB_SERVICE "Enable web services (telemetry, etc.)" ON)
@@ -224,6 +225,10 @@ if(ENABLE_QT)
if (YUZU_USE_QT_WEB_ENGINE)
find_package(Qt5 COMPONENTS WebEngineCore WebEngineWidgets)
endif()
+
+ if (ENABLE_QT_TRANSLATION)
+ find_package(Qt5 REQUIRED COMPONENTS LinguistTools ${QT_PREFIX_HINT})
+ endif()
if (NOT Qt5_FOUND)
list(APPEND CONAN_REQUIRED_LIBS "qt/5.14.1@bincrafters/stable")
endif()