summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMerryMage <MerryMage@users.noreply.github.com>2017-07-16 20:52:05 +0200
committerMerryMage <MerryMage@users.noreply.github.com>2017-07-16 20:52:05 +0200
commit9ca672821737f571daddbe8480ef1f6f998eb536 (patch)
tree2304ac955adf66bc980b70c9d45b8c358c86b2c2 /CMakeLists.txt
parentMerge pull request #2784 from wwylele/font-archive (diff)
downloadyuzu-9ca672821737f571daddbe8480ef1f6f998eb536.tar
yuzu-9ca672821737f571daddbe8480ef1f6f998eb536.tar.gz
yuzu-9ca672821737f571daddbe8480ef1f6f998eb536.tar.bz2
yuzu-9ca672821737f571daddbe8480ef1f6f998eb536.tar.lz
yuzu-9ca672821737f571daddbe8480ef1f6f998eb536.tar.xz
yuzu-9ca672821737f571daddbe8480ef1f6f998eb536.tar.zst
yuzu-9ca672821737f571daddbe8480ef1f6f998eb536.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad73cf495..9151ff786 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,21 @@ if(NOT EXISTS ${CMAKE_SOURCE_DIR}/.git/hooks/pre-commit)
DESTINATION ${CMAKE_SOURCE_DIR}/.git/hooks)
endif()
+# Sanity check : Check that all submodules are present
+# =======================================================================
+
+function(check_submodules_present)
+ file(READ "${CMAKE_SOURCE_DIR}/.gitmodules" gitmodules)
+ string(REGEX MATCHALL "path *= *[^ \t\r\n]*" gitmodules ${gitmodules})
+ foreach(module ${gitmodules})
+ string(REGEX REPLACE "path *= *" "" module ${module})
+ if (NOT EXISTS "${CMAKE_SOURCE_DIR}/${module}/.git")
+ message(SEND_ERROR "Git submodule ${module} not found."
+ "Please run: git submodule update --init --recursive")
+ endif()
+ endforeach()
+endfunction()
+check_submodules_present()
# Detect current compilation architecture and create standard definitions
# =======================================================================