summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAmeer J <52414509+ameerj@users.noreply.github.com>2021-08-01 07:34:10 +0200
committerGitHub <noreply@github.com>2021-08-01 07:34:10 +0200
commita086ee6a0021b0d9cb5a4a1fb609220f4114fb97 (patch)
tree5d8e650db36e62fe64099964e6ead564855982f4 /CMakeLists.txt
parentMerge pull request #6788 from Morph1984/hle_api_12.1.0 (diff)
parentcmake: Specify the compiler on autotools externals (diff)
downloadyuzu-a086ee6a0021b0d9cb5a4a1fb609220f4114fb97.tar
yuzu-a086ee6a0021b0d9cb5a4a1fb609220f4114fb97.tar.gz
yuzu-a086ee6a0021b0d9cb5a4a1fb609220f4114fb97.tar.bz2
yuzu-a086ee6a0021b0d9cb5a4a1fb609220f4114fb97.tar.lz
yuzu-a086ee6a0021b0d9cb5a4a1fb609220f4114fb97.tar.xz
yuzu-a086ee6a0021b0d9cb5a4a1fb609220f4114fb97.tar.zst
yuzu-a086ee6a0021b0d9cb5a4a1fb609220f4114fb97.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d98ba7767..92c9929cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,7 @@ option(YUZU_USE_BUNDLED_BOOST "Download bundled Boost" OFF)
option(YUZU_USE_BUNDLED_LIBUSB "Compile bundled libusb" OFF)
-CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_FFMPEG "Download/Build bundled FFmpeg" ON "WIN32" OFF)
+option(YUZU_USE_BUNDLED_FFMPEG "Download/Build bundled FFmpeg" "${WIN32}")
option(YUZU_USE_QT_WEB_ENGINE "Use QtWebEngine for web applet implementation" OFF)
@@ -604,6 +604,8 @@ if (YUZU_USE_BUNDLED_FFMPEG)
--disable-vdpau
--enable-decoder=h264
--enable-decoder=vp9
+ --cc="${CMAKE_C_COMPILER}"
+ --cxx="${CMAKE_CXX_COMPILER}"
WORKING_DIRECTORY
${FFmpeg_BUILD_DIR}
)