summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorarchshift <admin@archshift.com>2014-05-01 01:56:25 +0200
committerarchshift <admin@archshift.com>2014-05-01 01:56:47 +0200
commita7f3ed003d03c79f83c1c354329e5ce47f6940e7 (patch)
tree76b0dd731d81ea91917f8a9c34c4e7c90db4f407 /CMakeLists.txt
parentSome more experimentation (diff)
downloadyuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.gz
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.bz2
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.lz
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.xz
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.zst
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49c1a384a..6837d36fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,14 @@ IF (APPLE)
SET(CMAKE_CXX_FLAGS_RELEASE "-stdlib=libc++")
ENDIF (APPLE)
+#external includes
include_directories(${GLFW_INCLUDE_DIRS})
+include_directories(${OPENGL_INCLUDE_DIR})
+include_directories(${GLEW_INCLUDE_DIR})
+
+#use pkg_search_module library dirs
+link_directories(${GLFW_LIBRARY_DIRS})
+
option(DISABLE_QT4 "Disable Qt4 GUI" OFF)
if(NOT DISABLE_QT4)
include(FindQt4)
@@ -47,10 +54,6 @@ include(GetGitRevisionDescription)
get_git_head_revision(GIT_REF_SPEC GIT_REV)
git_describe(GIT_DESC --always --long --dirty)
git_branch_name(GIT_BRANCH)
-
-# external includes
-include_directories(${OPENGL_INCLUDE_DIR})
-include_directories(${GLEW_INCLUDE_DIR})
# internal includes
include_directories(src)