summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2016-06-30 19:59:32 +0200
committerJames Rowe <jroweboy@gmail.com>2016-08-05 01:16:16 +0200
commita976c2e3ba146df2fda9293c6fce9e11d96ac038 (patch)
treed634a074059cbe7385843c9f9ad176acff64460e /CMakeLists.txt
parentInput GUI: Add tab to remap controls (#1900) (diff)
downloadyuzu-a976c2e3ba146df2fda9293c6fce9e11d96ac038.tar
yuzu-a976c2e3ba146df2fda9293c6fce9e11d96ac038.tar.gz
yuzu-a976c2e3ba146df2fda9293c6fce9e11d96ac038.tar.bz2
yuzu-a976c2e3ba146df2fda9293c6fce9e11d96ac038.tar.lz
yuzu-a976c2e3ba146df2fda9293c6fce9e11d96ac038.tar.xz
yuzu-a976c2e3ba146df2fda9293c6fce9e11d96ac038.tar.zst
yuzu-a976c2e3ba146df2fda9293c6fce9e11d96ac038.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 779eb8e50..4a271c36f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,5 @@
-# CMake 3.1 required for Qt5 settings to be applied automatically on
-# dependent libraries and IMPORTED targets.
-cmake_minimum_required(VERSION 3.1)
+# CMake 3.2 required for cmake to know the right flags for CXX standard on OSX
+cmake_minimum_required(VERSION 3.2)
function(download_bundled_external remote_path lib_name prefix_var)
set(prefix "${CMAKE_BINARY_DIR}/externals/${lib_name}")
@@ -63,8 +62,11 @@ if (NOT DEFINED ARCHITECTURE)
endif()
message(STATUS "Target architecture: ${ARCHITECTURE}")
+set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
if (NOT MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y -Wno-attributes")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-attributes")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS}")
else()
# Silence "deprecation" warnings