summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-21 07:51:28 +0200
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-22 20:09:40 +0200
commitad55faaa359e82bd65d2fd40a3aec2615e72f1a6 (patch)
tree5e67b8c62beb5c25ffe7b5a2ab1587f7420567bf /CMakeLists.txt
parentMerge pull request #6223 from lat9nq/ffmpeg-external-fixes (diff)
downloadyuzu-ad55faaa359e82bd65d2fd40a3aec2615e72f1a6.tar
yuzu-ad55faaa359e82bd65d2fd40a3aec2615e72f1a6.tar.gz
yuzu-ad55faaa359e82bd65d2fd40a3aec2615e72f1a6.tar.bz2
yuzu-ad55faaa359e82bd65d2fd40a3aec2615e72f1a6.tar.lz
yuzu-ad55faaa359e82bd65d2fd40a3aec2615e72f1a6.tar.xz
yuzu-ad55faaa359e82bd65d2fd40a3aec2615e72f1a6.tar.zst
yuzu-ad55faaa359e82bd65d2fd40a3aec2615e72f1a6.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 19 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7afa972f5..15ecb8a9c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,8 @@ CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_QT "Download bundled Qt binaries" ON "EN
option(ENABLE_WEB_SERVICE "Enable web services (telemetry, etc.)" ON)
+option(YUZU_USE_BUNDLED_BOOST "Download bundled Boost" OFF)
+
CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_FFMPEG "Download/Build bundled FFmpeg" ON "WIN32" OFF)
option(YUZU_USE_QT_WEB_ENGINE "Use QtWebEngine for web applet implementation" OFF)
@@ -199,7 +201,9 @@ macro(yuzu_find_packages)
unset(FN_FORCE_REQUIRED)
endmacro()
-find_package(Boost 1.73.0 COMPONENTS context headers QUIET)
+if (NOT YUZU_USE_BUNDLED_BOOST)
+ find_package(Boost 1.73.0 COMPONENTS context headers QUIET)
+endif()
if (Boost_FOUND)
set(Boost_LIBRARIES Boost::boost)
# Conditionally add Boost::context only if the active version of the Conan or system Boost package provides it
@@ -210,6 +214,20 @@ if (Boost_FOUND)
if (TARGET Boost::context)
list(APPEND Boost_LIBRARIES Boost::context)
endif()
+elseif (${CMAKE_SYSTEM_NAME} STREQUAL "Linux" OR YUZU_USE_BUNDLED_BOOST)
+ message(STATUS "Boost 1.73.0 or newer not found, falling back to externals")
+ set(YUZU_USE_BUNDLED_BOOST ON CACHE BOOL "Download bundled Boost" FORCE)
+
+ # Use yuzu Boost binaries
+ set(Boost_EXT_NAME "boost_1_75_0")
+ set(Boost_PATH "${CMAKE_BINARY_DIR}/externals/${Boost_EXT_NAME}")
+ download_bundled_external("boost/" ${Boost_EXT_NAME} "")
+ set(Boost_USE_DEBUG_RUNTIME FALSE)
+ set(Boost_USE_STATIC_LIBS ON)
+ find_package(Boost 1.75.0 REQUIRED COMPONENTS context headers PATHS ${Boost_PATH} NO_DEFAULT_PATH)
+ # Manually set the include dirs since the find_package sets it incorrectly
+ set(Boost_INCLUDE_DIRS ${Boost_PATH}/include CACHE PATH "Path to Boost headers" FORCE)
+ include_directories(SYSTEM "${Boost_INCLUDE_DIRS}")
else()
message(STATUS "Boost 1.73.0 or newer not found, falling back to Conan")
list(APPEND CONAN_REQUIRED_LIBS "boost/1.73.0")