summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHedges <hedges@resync.pl>2018-11-13 16:44:20 +0100
committerHedges <hedges@resync.pl>2018-11-13 16:44:20 +0100
commitaf423200219aee29c50336420f772348f0ed8437 (patch)
tree00dbd1444fc5a9509b19bdffbb8ab44046d2ad8e /CMakeLists.txt
parentMerge pull request #1628 from greggameplayer/Texture2DArray (diff)
downloadyuzu-af423200219aee29c50336420f772348f0ed8437.tar
yuzu-af423200219aee29c50336420f772348f0ed8437.tar.gz
yuzu-af423200219aee29c50336420f772348f0ed8437.tar.bz2
yuzu-af423200219aee29c50336420f772348f0ed8437.tar.lz
yuzu-af423200219aee29c50336420f772348f0ed8437.tar.xz
yuzu-af423200219aee29c50336420f772348f0ed8437.tar.zst
yuzu-af423200219aee29c50336420f772348f0ed8437.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 918cf5372..1f71f9fd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -377,7 +377,7 @@ if (CLANG_FORMAT)
set(CCOMMENT "Running clang format against all the .h and .cpp files in src/")
if (WIN32)
add_custom_target(clang-format
- COMMAND powershell.exe -Command "${CLANG_FORMAT} -i @(Get-ChildItem -Recurse ${SRCS}/* -Include \'*.h\', \'*.cpp\')"
+ COMMAND powershell.exe -Command "Get-ChildItem ${SRCS}/* -Include *.cpp,*.h -Recurse | Foreach {${CLANG_FORMAT} -i $_.fullname}"
COMMENT ${CCOMMENT})
elseif(MINGW)
add_custom_target(clang-format