summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-10-06 08:43:09 +0200
committerGitHub <noreply@github.com>2018-10-06 08:43:09 +0200
commitb8b90ce6e61329ebda226b9917ed961be3b80d1f (patch)
tree8e6b82419db7fb24eb5d8f06346a0a1228f9513c /CMakeLists.txt
parentMerge pull request #1447 from lioncash/mutex (diff)
parentReview comments - part 5 (diff)
downloadyuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.gz
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.bz2
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.lz
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.xz
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.zst
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92c3e855c..6021a8054 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,10 +15,14 @@ CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_SDL2 "Download bundled SDL2 binaries" ON
option(ENABLE_QT "Enable the Qt frontend" ON)
CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_QT "Download bundled Qt binaries" ON "ENABLE_QT;MSVC" OFF)
+option(ENABLE_WEB_SERVICE "Enable web services (telemetry, etc.)" ON)
+
option(YUZU_USE_BUNDLED_UNICORN "Build/Download bundled Unicorn" ON)
option(ENABLE_CUBEB "Enables the cubeb audio backend" ON)
+option(USE_DISCORD_PRESENCE "Enables Discord Rich Presence" OFF)
+
if(NOT EXISTS ${CMAKE_SOURCE_DIR}/.git/hooks/pre-commit)
message(STATUS "Copying pre-commit hook")
file(COPY hooks/pre-commit