summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMerryMage <MerryMage@users.noreply.github.com>2018-01-21 14:29:05 +0100
committerMerryMage <MerryMage@users.noreply.github.com>2018-01-21 14:58:39 +0100
commitbba785d643ad05ae11d13c9e9be4cc93650d1a2b (patch)
treebafde12c6e80d5de8b0629a03c5639eb375d87ac /CMakeLists.txt
parentMerge pull request #72 from N00byKing/patch-2 (diff)
downloadyuzu-bba785d643ad05ae11d13c9e9be4cc93650d1a2b.tar
yuzu-bba785d643ad05ae11d13c9e9be4cc93650d1a2b.tar.gz
yuzu-bba785d643ad05ae11d13c9e9be4cc93650d1a2b.tar.bz2
yuzu-bba785d643ad05ae11d13c9e9be4cc93650d1a2b.tar.lz
yuzu-bba785d643ad05ae11d13c9e9be4cc93650d1a2b.tar.xz
yuzu-bba785d643ad05ae11d13c9e9be4cc93650d1a2b.tar.zst
yuzu-bba785d643ad05ae11d13c9e9be4cc93650d1a2b.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5dee41abc..4ecae84b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,8 @@ CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_SDL2 "Download bundled SDL2 binaries" ON
option(ENABLE_QT "Enable the Qt frontend" ON)
CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_QT "Download bundled Qt binaries" ON "ENABLE_SDL2;MSVC" OFF)
+option(YUZU_USE_BUNDLED_UNICORN "Build/Download bundled Unicorn" ON)
+
if(NOT EXISTS ${CMAKE_SOURCE_DIR}/.git/hooks/pre-commit)
message(STATUS "Copying pre-commit hook")
file(COPY hooks/pre-commit
@@ -209,8 +211,7 @@ else()
endif()
# If unicorn isn't found, msvc -> download bundled unicorn; everyone else -> build external
-find_package(Unicorn QUIET)
-if (NOT UNICORN_FOUND)
+if (YUZU_USE_BUNDLED_UNICORN)
if (MSVC)
message(STATUS "unicorn not found, falling back to bundled")
# Detect toolchain and platform
@@ -259,6 +260,8 @@ if (NOT UNICORN_FOUND)
)
unset(UNICORN_LIB_NAME)
endif()
+else()
+ find_package(Unicorn REQUIRED)
endif()
if (UNICORN_FOUND)