summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2015-05-07 03:59:59 +0200
committerYuri Kunde Schlesner <yuriks@yuriks.net>2015-05-07 04:50:08 +0200
commitbf12f270b3c74f694c789a57cc69f414753ca080 (patch)
treea80e6ee9863a46966fe43496f1ccbbfa07cc98aa /CMakeLists.txt
parentClean-up includes (diff)
downloadyuzu-bf12f270b3c74f694c789a57cc69f414753ca080.tar
yuzu-bf12f270b3c74f694c789a57cc69f414753ca080.tar.gz
yuzu-bf12f270b3c74f694c789a57cc69f414753ca080.tar.bz2
yuzu-bf12f270b3c74f694c789a57cc69f414753ca080.tar.lz
yuzu-bf12f270b3c74f694c789a57cc69f414753ca080.tar.xz
yuzu-bf12f270b3c74f694c789a57cc69f414753ca080.tar.zst
yuzu-bf12f270b3c74f694c789a57cc69f414753ca080.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 516aba554..b0fe285db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,11 @@ if (NOT MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-attributes -pthread")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
else()
- # Silence deprecation warnings
- add_definitions(/D_CRT_SECURE_NO_WARNINGS)
+ # Silence "deprecation" warnings
+ add_definitions(/D_CRT_SECURE_NO_WARNINGS /D_CRT_NONSTDC_NO_DEPRECATE)
+ # Avoid windows.h junk
+ add_definitions(/DNOMINMAX)
+
# set up output paths for executable binaries (.exe-files, and .dll-files on DLL-capable platforms)
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)