summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Spilsbury <smspillaz@gmail.com>2016-03-27 05:59:50 +0200
committerSam Spilsbury <smspillaz@gmail.com>2016-04-23 05:48:58 +0200
commitd051bd303225838e0e50a3e3ddc22337c1fc0f0c (patch)
treed054f69d2cc8f03c4d73c2e74deb42ee5556be0d /CMakeLists.txt
parentMerge pull request #1697 from tfarley/hw-lighting-sync (diff)
downloadyuzu-d051bd303225838e0e50a3e3ddc22337c1fc0f0c.tar
yuzu-d051bd303225838e0e50a3e3ddc22337c1fc0f0c.tar.gz
yuzu-d051bd303225838e0e50a3e3ddc22337c1fc0f0c.tar.bz2
yuzu-d051bd303225838e0e50a3e3ddc22337c1fc0f0c.tar.lz
yuzu-d051bd303225838e0e50a3e3ddc22337c1fc0f0c.tar.xz
yuzu-d051bd303225838e0e50a3e3ddc22337c1fc0f0c.tar.zst
yuzu-d051bd303225838e0e50a3e3ddc22337c1fc0f0c.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a0a161e7..ddde19760 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,8 +65,8 @@ endif()
message(STATUS "Target architecture: ${ARCHITECTURE}")
if (NOT MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y -Wno-attributes -pthread")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y -Wno-attributes")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS}")
if (ARCHITECTURE_x86_64)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse4.1")
@@ -135,6 +135,8 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/externals/cmake-modules")
find_package(OpenGL REQUIRED)
include_directories(${OPENGL_INCLUDE_DIR})
+find_package(Threads REQUIRED)
+
if (ENABLE_SDL2)
if (CITRA_USE_BUNDLED_SDL2)
# Detect toolchain and platform