summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2016-06-17 15:16:12 +0200
committerLioncash <mathew1800@gmail.com>2016-06-17 16:48:40 +0200
commitd5f5aeeab8ea030f92ad9e30a042a90c8c2762b0 (patch)
treeef209ace0b158cb1d82e5c1cfbbde0b7e27a2b36 /CMakeLists.txt
parenttravis: Use GCC 6 on Ubuntu CI builds (diff)
downloadyuzu-d5f5aeeab8ea030f92ad9e30a042a90c8c2762b0.tar
yuzu-d5f5aeeab8ea030f92ad9e30a042a90c8c2762b0.tar.gz
yuzu-d5f5aeeab8ea030f92ad9e30a042a90c8c2762b0.tar.bz2
yuzu-d5f5aeeab8ea030f92ad9e30a042a90c8c2762b0.tar.lz
yuzu-d5f5aeeab8ea030f92ad9e30a042a90c8c2762b0.tar.xz
yuzu-d5f5aeeab8ea030f92ad9e30a042a90c8c2762b0.tar.zst
yuzu-d5f5aeeab8ea030f92ad9e30a042a90c8c2762b0.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7b0af115..9a436b981 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,7 +40,6 @@ option(CITRA_USE_BUNDLED_SDL2 "Download bundled SDL2 binaries" OFF)
option(ENABLE_QT "Enable the Qt frontend" ON)
option(CITRA_USE_BUNDLED_QT "Download bundled Qt binaries" OFF)
-option(CITRA_FORCE_QT4 "Use Qt4 even if Qt5 is available." OFF)
if(NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git/hooks/pre-commit)
message(STATUS "Copying pre-commit hook")
@@ -201,16 +200,8 @@ if (ENABLE_QT)
set(QT_PREFIX_HINT)
endif()
- if (NOT CITRA_FORCE_QT4)
- find_package(Qt5 COMPONENTS Widgets OpenGL ${QT_PREFIX_HINT})
- set(CITRA_QT_LIBS Qt5::Widgets Qt5::OpenGL)
- endif()
-
- if (CITRA_FORCE_QT4 OR NOT Qt5_FOUND)
- # Try to fallback to Qt4
- find_package(Qt4 REQUIRED COMPONENTS QtGui QtOpenGL ${QT_PREFIX_HINT})
- set(CITRA_QT_LIBS Qt4::QtGui Qt4::QtOpenGL)
- endif()
+ find_package(Qt5 REQUIRED COMPONENTS Widgets OpenGL ${QT_PREFIX_HINT})
+ set(CITRA_QT_LIBS Qt5::Widgets Qt5::OpenGL)
endif()
# This function should be passed a list of all files in a target. It will automatically generate