summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2017-05-28 07:34:52 +0200
committerYuri Kunde Schlesner <yuriks@yuriks.net>2017-05-28 07:34:52 +0200
commitd736cca848a12788652e366b5554063c99f06cca (patch)
tree9ad4ff2c52c782fe7b972712cbbfb608c37555aa /CMakeLists.txt
parentCMake: Remove unnecessary include_directories for dynarmic (diff)
downloadyuzu-d736cca848a12788652e366b5554063c99f06cca.tar
yuzu-d736cca848a12788652e366b5554063c99f06cca.tar.gz
yuzu-d736cca848a12788652e366b5554063c99f06cca.tar.bz2
yuzu-d736cca848a12788652e366b5554063c99f06cca.tar.lz
yuzu-d736cca848a12788652e366b5554063c99f06cca.tar.xz
yuzu-d736cca848a12788652e366b5554063c99f06cca.tar.zst
yuzu-d736cca848a12788652e366b5554063c99f06cca.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f099fd34..9e586633c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -263,8 +263,12 @@ set(DYNARMIC_NO_BUNDLED_FMT ON)
add_subdirectory(externals/dynarmic)
add_subdirectory(externals/glad)
-include_directories(externals/microprofile)
-include_directories(externals/nihstro/include)
+
+add_library(microprofile INTERFACE)
+target_include_directories(microprofile INTERFACE externals/microprofile)
+
+add_library(nihstro-headers INTERFACE)
+target_include_directories(nihstro-headers INTERFACE externals/nihstro/include)
if (MSVC)
add_subdirectory(externals/getopt)