summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-18 05:35:13 +0200
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-18 05:42:57 +0200
commitde69a5266fde93a793fc3664db205ec7bad3e9a9 (patch)
tree6d14faea4a91e9cd8e5a516712b677354a92a41b /CMakeLists.txt
parentMerge pull request #6204 from lat9nq/sdl2-external (diff)
downloadyuzu-de69a5266fde93a793fc3664db205ec7bad3e9a9.tar
yuzu-de69a5266fde93a793fc3664db205ec7bad3e9a9.tar.gz
yuzu-de69a5266fde93a793fc3664db205ec7bad3e9a9.tar.bz2
yuzu-de69a5266fde93a793fc3664db205ec7bad3e9a9.tar.lz
yuzu-de69a5266fde93a793fc3664db205ec7bad3e9a9.tar.xz
yuzu-de69a5266fde93a793fc3664db205ec7bad3e9a9.tar.zst
yuzu-de69a5266fde93a793fc3664db205ec7bad3e9a9.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e208715d7..2c1c3d560 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -274,9 +274,9 @@ if (ENABLE_SDL2)
target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARY}")
target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
else()
- find_package(SDL2 2.0.12)
+ find_package(SDL2 2.0.14)
- if(SDL2_FOUND)
+ if (SDL2_FOUND)
# Some installations don't set SDL2_LIBRARIES
if("${SDL2_LIBRARIES}" STREQUAL "")
message(WARNING "SDL2_LIBRARIES wasn't set, manually setting to SDL2::SDL2")
@@ -286,10 +286,10 @@ if (ENABLE_SDL2)
include_directories(SYSTEM ${SDL2_INCLUDE_DIRS})
add_library(SDL2 INTERFACE)
target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARIES}")
+ else()
+ message(STATUS "SDL2 2.0.14 or newer not found, falling back to externals.")
endif()
endif()
-else()
- set(SDL2_FOUND NO)
endif()
# Install any missing dependencies with conan install