summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2019-03-16 01:49:55 +0100
committerLioncash <mathew1800@gmail.com>2019-03-16 01:49:58 +0100
commite5b004e9037359818ecc5a1d679c8d19d4a801b0 (patch)
treebca1488eaf0536e2fe93dbfd39ca7e3aa81d9e1a /CMakeLists.txt
parentMerge pull request #2211 from lioncash/arbiter (diff)
downloadyuzu-e5b004e9037359818ecc5a1d679c8d19d4a801b0.tar
yuzu-e5b004e9037359818ecc5a1d679c8d19d4a801b0.tar.gz
yuzu-e5b004e9037359818ecc5a1d679c8d19d4a801b0.tar.bz2
yuzu-e5b004e9037359818ecc5a1d679c8d19d4a801b0.tar.lz
yuzu-e5b004e9037359818ecc5a1d679c8d19d4a801b0.tar.xz
yuzu-e5b004e9037359818ecc5a1d679c8d19d4a801b0.tar.zst
yuzu-e5b004e9037359818ecc5a1d679c8d19d4a801b0.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 32cfa8580..9cc24cba6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,12 +163,6 @@ else()
set(CMAKE_EXE_LINKER_FLAGS_RELEASE "/DEBUG /MANIFEST:NO /INCREMENTAL:NO /OPT:REF,ICF" CACHE STRING "" FORCE)
endif()
-# Fix GCC C++17 and Boost.ICL incompatibility (needed to build dynarmic)
-# See https://bugzilla.redhat.com/show_bug.cgi?id=1485641#c1
-if (CMAKE_COMPILER_IS_GNUCC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-new-ttp-matching")
-endif()
-
# Set file offset size to 64 bits.
#
# On modern Unixes, this is typically already the case. The lone exception is
@@ -185,9 +179,9 @@ set_property(DIRECTORY APPEND PROPERTY
# System imported libraries
# ======================
-find_package(Boost 1.63.0 QUIET)
+find_package(Boost 1.64.0 QUIET)
if (NOT Boost_FOUND)
- message(STATUS "Boost 1.63.0 or newer not found, falling back to externals")
+ message(STATUS "Boost 1.64.0 or newer not found, falling back to externals")
set(BOOST_ROOT "${PROJECT_SOURCE_DIR}/externals/boost")
set(Boost_NO_SYSTEM_PATHS OFF)