summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Hilman <zachhilman@gmail.com>2018-12-24 22:24:01 +0100
committerZach Hilman <zachhilman@gmail.com>2018-12-28 21:32:39 +0100
commitef4c4e239da8e5771f61bf079eae25b28cbd0318 (patch)
treec9d26a55a5ca150de64adf33ed14eb6cfcf1144f /CMakeLists.txt
parentmain: Add main window integrations for QtWebBrowserApplet (diff)
downloadyuzu-ef4c4e239da8e5771f61bf079eae25b28cbd0318.tar
yuzu-ef4c4e239da8e5771f61bf079eae25b28cbd0318.tar.gz
yuzu-ef4c4e239da8e5771f61bf079eae25b28cbd0318.tar.bz2
yuzu-ef4c4e239da8e5771f61bf079eae25b28cbd0318.tar.lz
yuzu-ef4c4e239da8e5771f61bf079eae25b28cbd0318.tar.xz
yuzu-ef4c4e239da8e5771f61bf079eae25b28cbd0318.tar.zst
yuzu-ef4c4e239da8e5771f61bf079eae25b28cbd0318.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f71f9fd9..f8635d91f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,8 @@ option(ENABLE_WEB_SERVICE "Enable web services (telemetry, etc.)" ON)
option(YUZU_USE_BUNDLED_UNICORN "Build/Download bundled Unicorn" ON)
+option(YUZU_USE_QT_WEB_ENGINE "Use QtWebEngine for web applet implementation" OFF)
+
option(ENABLE_CUBEB "Enables the cubeb audio backend" ON)
option(USE_DISCORD_PRESENCE "Enables Discord Rich Presence" OFF)
@@ -319,6 +321,10 @@ if (ENABLE_QT)
endif()
find_package(Qt5 REQUIRED COMPONENTS Widgets OpenGL ${QT_PREFIX_HINT})
+
+ if (YUZU_USE_QT_WEB_ENGINE)
+ find_package(Qt5 REQUIRED COMPONENTS WebEngineCore WebEngineWidgets ${QT_PREFIX_HINT})
+ endif ()
endif()
# Platform-specific library requirements