summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2015-01-09 15:42:35 +0100
committerYuri Kunde Schlesner <yuriks@yuriks.net>2015-01-09 15:42:35 +0100
commitf983d955f9cd01bc07f8c3dddb0565e66a0d2990 (patch)
treecb012468d60f8eeaf3f101718264b2720c1450c7 /CMakeLists.txt
parentMerge pull request #255 from Subv/cbranch_3 (diff)
downloadyuzu-f983d955f9cd01bc07f8c3dddb0565e66a0d2990.tar
yuzu-f983d955f9cd01bc07f8c3dddb0565e66a0d2990.tar.gz
yuzu-f983d955f9cd01bc07f8c3dddb0565e66a0d2990.tar.bz2
yuzu-f983d955f9cd01bc07f8c3dddb0565e66a0d2990.tar.lz
yuzu-f983d955f9cd01bc07f8c3dddb0565e66a0d2990.tar.xz
yuzu-f983d955f9cd01bc07f8c3dddb0565e66a0d2990.tar.zst
yuzu-f983d955f9cd01bc07f8c3dddb0565e66a0d2990.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 884520cef..2cba5e8a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,7 @@ else()
# As far as I can tell, there's no way to override the CMake defaults while leaving user
# changes intact, so we'll just clobber everything and say sorry.
message(STATUS "Cache compiler flags ignored, please edit CMakeFiles.txt to change the flags.")
+ # /MP - Multi-threaded compilation
# /MD - Multi-threaded runtime
# /Ox - Full optimization
# /Oi - Use intrinsic functions
@@ -24,7 +25,7 @@ else()
# /GR- - Disable RTTI
# /GS- - No stack buffer overflow checks
# /EHsc - C++-only exception handling semantics
- set(optimization_flags "/MD /Ox /Oi /Oy- /DNDEBUG /GR- /GS- /EHsc")
+ set(optimization_flags "/MP /MD /Ox /Oi /Oy- /DNDEBUG /GR- /GS- /EHsc")
# /Zi - Output debugging information
# /Zo - enahnced debug info for optimized builds
set(CMAKE_C_FLAGS_RELEASE "${optimization_flags} /Zi" CACHE STRING "" FORCE)