summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-07-11 01:24:23 +0200
committerLioncash <mathew1800@gmail.com>2020-07-11 10:45:40 +0200
commitfb0fefc75c3cb9e060d59f3b10fe3ae66626aeb8 (patch)
tree6d3718ccfacf535d2738f7a824b0abec2c945115 /CMakeLists.txt
parentMerge pull request #4221 from jbeich/unused-qt-opengl (diff)
downloadyuzu-fb0fefc75c3cb9e060d59f3b10fe3ae66626aeb8.tar
yuzu-fb0fefc75c3cb9e060d59f3b10fe3ae66626aeb8.tar.gz
yuzu-fb0fefc75c3cb9e060d59f3b10fe3ae66626aeb8.tar.bz2
yuzu-fb0fefc75c3cb9e060d59f3b10fe3ae66626aeb8.tar.lz
yuzu-fb0fefc75c3cb9e060d59f3b10fe3ae66626aeb8.tar.xz
yuzu-fb0fefc75c3cb9e060d59f3b10fe3ae66626aeb8.tar.zst
yuzu-fb0fefc75c3cb9e060d59f3b10fe3ae66626aeb8.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c0e49c03..c8e86959b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,8 +118,15 @@ message(STATUS "Target architecture: ${ARCHITECTURE}")
# Configure C++ standard
# ===========================
-set(CMAKE_CXX_STANDARD 17)
-set(CMAKE_CXX_STANDARD_REQUIRED ON)
+if (MSVC)
+ add_compile_options(/std:c++latest)
+
+ # cubeb and boost still make use of deprecated result_of.
+ add_definitions(-D_HAS_DEPRECATED_RESULT_OF)
+else()
+ set(CMAKE_CXX_STANDARD 17)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+endif()
# Output binaries to bin/
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/bin)