summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2021-07-06 18:06:14 +0200
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2021-07-06 18:28:22 +0200
commitfbb26e6173aee296bdfb6083c553d843ece58ccc (patch)
tree139fa8a19508a2abc2e36974dd5ef03ea6028598 /CMakeLists.txt
parentMerge pull request #6561 from german77/analog_fix (diff)
downloadyuzu-fbb26e6173aee296bdfb6083c553d843ece58ccc.tar
yuzu-fbb26e6173aee296bdfb6083c553d843ece58ccc.tar.gz
yuzu-fbb26e6173aee296bdfb6083c553d843ece58ccc.tar.bz2
yuzu-fbb26e6173aee296bdfb6083c553d843ece58ccc.tar.lz
yuzu-fbb26e6173aee296bdfb6083c553d843ece58ccc.tar.xz
yuzu-fbb26e6173aee296bdfb6083c553d843ece58ccc.tar.zst
yuzu-fbb26e6173aee296bdfb6083c553d843ece58ccc.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b1734f36..38a141652 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,7 @@ option(YUZU_USE_BUNDLED_BOOST "Download bundled Boost" OFF)
option(YUZU_USE_BUNDLED_LIBUSB "Compile bundled libusb" OFF)
-CMAKE_DEPENDENT_OPTION(YUZU_USE_BUNDLED_FFMPEG "Download/Build bundled FFmpeg" ON "WIN32" OFF)
+option(YUZU_USE_BUNDLED_FFMPEG "Download/Build bundled FFmpeg" "${WIN32}")
option(YUZU_USE_QT_WEB_ENGINE "Use QtWebEngine for web applet implementation" OFF)
@@ -253,7 +253,9 @@ if(ENABLE_QT)
# Check for system Qt on Linux, fallback to bundled Qt
if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
- find_package(Qt5 ${QT_VERSION} COMPONENTS Widgets)
+ if (NOT YUZU_USE_BUNDLED_QT)
+ find_package(Qt5 ${QT_VERSION} COMPONENTS Widgets)
+ endif()
if (NOT Qt5_FOUND OR YUZU_USE_BUNDLED_QT)
# Check for dependencies, then enable bundled Qt download