summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorFranco M <francomaro@gmail.com>2023-10-27 00:11:15 +0200
committerGitHub <noreply@github.com>2023-10-27 00:11:15 +0200
commitb5415b687203599fe18e2cefc78700e4c6f2ae7c (patch)
treeddd4c82cab9e367cdcf2bbf4a1d444f85ed0b02e /externals/CMakeLists.txt
parentMerge branch 'yuzu-emu:master' into new-shortcut (diff)
parentMerge pull request #11880 from abouvier/unbundle-stb (diff)
downloadyuzu-b5415b687203599fe18e2cefc78700e4c6f2ae7c.tar
yuzu-b5415b687203599fe18e2cefc78700e4c6f2ae7c.tar.gz
yuzu-b5415b687203599fe18e2cefc78700e4c6f2ae7c.tar.bz2
yuzu-b5415b687203599fe18e2cefc78700e4c6f2ae7c.tar.lz
yuzu-b5415b687203599fe18e2cefc78700e4c6f2ae7c.tar.xz
yuzu-b5415b687203599fe18e2cefc78700e4c6f2ae7c.tar.zst
yuzu-b5415b687203599fe18e2cefc78700e4c6f2ae7c.zip
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index b1fd3ac62..6e5bfbba6 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -168,9 +168,13 @@ if (NOT TARGET LLVM::Demangle)
add_library(LLVM::Demangle ALIAS demangle)
endif()
-add_library(stb stb/stb_dxt.cpp stb/stb_image.cpp stb/stb_image_resize.cpp)
+add_library(stb stb/stb_dxt.cpp)
target_include_directories(stb PUBLIC ./stb)
+if (NOT TARGET stb::headers)
+ add_library(stb::headers ALIAS stb)
+endif()
+
add_library(bc_decoder bc_decoder/bc_decoder.cpp)
target_include_directories(bc_decoder PUBLIC ./bc_decoder)