summaryrefslogtreecommitdiffstats
path: root/externals/getopt/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2018-01-18 01:37:34 +0100
committerLioncash <mathew1800@gmail.com>2018-01-18 03:51:43 +0100
commite710a1b9894d835d740ed63c03098fd637f61f63 (patch)
tree7585a15cdf38ea2913a847c738c84e769e43ea77 /externals/getopt/CMakeLists.txt
parentMerge pull request #73 from N00byKing/3093 (diff)
downloadyuzu-e710a1b9894d835d740ed63c03098fd637f61f63.tar
yuzu-e710a1b9894d835d740ed63c03098fd637f61f63.tar.gz
yuzu-e710a1b9894d835d740ed63c03098fd637f61f63.tar.bz2
yuzu-e710a1b9894d835d740ed63c03098fd637f61f63.tar.lz
yuzu-e710a1b9894d835d740ed63c03098fd637f61f63.tar.xz
yuzu-e710a1b9894d835d740ed63c03098fd637f61f63.tar.zst
yuzu-e710a1b9894d835d740ed63c03098fd637f61f63.zip
Diffstat (limited to 'externals/getopt/CMakeLists.txt')
-rw-r--r--externals/getopt/CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/externals/getopt/CMakeLists.txt b/externals/getopt/CMakeLists.txt
index c8b745d55..ad7a2b363 100644
--- a/externals/getopt/CMakeLists.txt
+++ b/externals/getopt/CMakeLists.txt
@@ -1,11 +1,9 @@
-set(SRCS
- getopt.c
- )
-set(HEADERS
- getopt.h
- )
+add_library(getopt
+ getopt.c
+ getopt.h
+)
+
+create_target_directory_groups(getopt)
-create_directory_groups(${SRCS} ${HEADERS})
-add_library(getopt ${SRCS} ${HEADERS})
target_compile_definitions(getopt PUBLIC STATIC_GETOPT)
target_include_directories(getopt INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})